External USB-C monitor stop working randomly

I had this problem randomly. Mostly when I disconnect monitor and then for a while replug it.

Haward: Dell Latitude 7490.
Monitor: Dell 2719DC
Ubuntu 20.04
Cable: Compliment the Dell Monitor. Using Display port via USB-C as a hub for keyboard and mouse.

Ubuntu still detect power and keyboard and mouse and usb hub. But no signal to monitor.

It might not a problem with cable or hardware because it would work after a restart. Links I’ve followed:

Force the signal to external without detection, and port is disconnected.

https://askubuntu.com/questions/150879/can-i-force-vga-signal-output-even-when-xrandr-shows-disconnected

xrandr –output eDP-1 –mode 1920×1080
xrandr –addmode DP-1 1920×1080
xrandr –output DP-1 –mode 1920×1080 –same-as eDP-1

Before

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920×1080+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
1920×1080 60.05*+ 60.01 59.97 59.96 59.93 48.04
1680×1050 59.95 59.88



360×202 59.51 59.13
320×180 59.84 59.32
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis) 0mm x 0mm
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-1-1 disconnected (normal left inverted right x axis y axis)
DP-1-1-8 disconnected (normal left inverted right x axis y axis)
DP-1-1-1 disconnected (normal left inverted right x axis y axis)

After, the xrandr still be shown as disconnected, but it actual duplicate the screen. It’s a workaround., I can’t make it work with correct resolution.




HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected 1920×1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1920×1080 60.05*
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-1-1 disconnected (normal left inverted right x axis y axis)
DP-1-1-8 disconnected (normal left inverted right x axis y axis)
DP-1-1-1 disconnected (normal left inverted right x axis y axis)

I followed these guides and hope it won’t happen again.

https://askubuntu.com/questions/1099873/dell-d6000-displaylink-dock-blanks-screens/1191089#1191089

https://www.synaptics.com/products/displaylink-graphics/downloads/ubuntu

Please mind if you want to install latest driver you need to setup password for secure boot or disable securce boot. In next boot please choose the second option, to change it. You would be asked password character at random position.

Trả lời

Điền thông tin vào ô dưới đây hoặc nhấn vào một biểu tượng để đăng nhập:

WordPress.com Logo

Bạn đang bình luận bằng tài khoản WordPress.com Đăng xuất /  Thay đổi )

Google photo

Bạn đang bình luận bằng tài khoản Google Đăng xuất /  Thay đổi )

Twitter picture

Bạn đang bình luận bằng tài khoản Twitter Đăng xuất /  Thay đổi )

Facebook photo

Bạn đang bình luận bằng tài khoản Facebook Đăng xuất /  Thay đổi )

Connecting to %s